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Chương 1: Căn bản về phần mềm MicroStation 
Chương này cung cấp một số khái niệm cơ bản về file, cấu trúc một file dữ liệu 

trong MicroStation và hướng dẫn các bạn thực hành một số các thao tác cơ bản khi 
làm việc với MicroStation, bao gồm: 

- Làm việc với các Design file. 
- Cấu trúc của một Design file. 
- Đối tượng đồ hoạ. 
- Thao tác điều khiển màn hình. 
- Cách sử dụng các phím chuột. 
- Các chế độ bắt điểm. 
- Sử dụng các công cụ trong MicroStation 

1. Làm việc với các Design File. 

File dữ liệu của MicroStation gọi là Design file (.dgn). Tại một thời điểm 
MicroStation chỉ cho phép người sử dụng làm việc với một Design file. File này gọi là 
Active Design File. 

Nếu bạn mở một Design file khi đã có một Design file khác đang mở sẵn, 
MicroStation sẽ tự động đóng file đầu tiên lại. Tuy nhiên bạn có thể xem (tham khảo) 
nội dung của các Design file khác bằng cách tác động đến các file đó dưới dạng các 
file tham khảo (Reference File). 

Một Design file trong MicroStation được tạo bằng cách copy một file chuẩn gọi 
là Seed File. 

1.1. Cách tạo Design file 

Cách 1: 
1. Khởi động MicroStation, xuất hiện hộp hội thoại MicroStation Manager. 
2. Từ File → New, xuất hiện hộp hội thoại Create Design File. 
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3. Đánh tên file vào hộp text Files. Ví dụ: Study.dgn. 
4. Chọn Seed file bằng cách bấm vào nút Select... Xuất hiện hộp hội thoại 

Select Seed File . 
 

 
 
5. Chọn đường dẫn đến tên thư mục và tên seed file cho bản đồ của mình. 

Ví dụ: File seed_hn72.dgn sẽ là seed file được chọn cho bản đồ Study.dgn. 
6. Bấm phím OK để đóng hộp hội thoại Select Seed File. 
7. Chọn thư mục chứa file bằng cách nhấp đôi vào các thư mục bên hộp danh 

sách các thư mục. 
8. Bấm phím OK để xoá hộp hội thoại Create Design File. 
 
Cách 2: 
Để tạo một file mới khi đang làm việc với một Design File bằng cách từ menu 

File → New, xuất hiện hộp hội thoại Create Design File. Tiếp tục làm từ bước 3 trở đi. 
1.2. Cách mở một Design file dưới dạng Active design file. 

Cách 1: Chọn thư mục chứa file và tên file từ hộp hội thoại MicroSttaion 
Manager và bấm OK. 

Cách 2:  
Từ thanh Menu chọn File → Open, xuất hiện hộp hội thoại Open Design File. 
1. Từ List file of Type chọn (*.dgn) nếu chưa có sẵn. Khi đó tất cả các file có 

đuôi (.dgn) sẽ xuất hiện trên hộp danh sách tên file. 
2. Chọn thư mục chứa file bằng cách nhấp đôi vào các thư mục bên hộp danh 

sách các thư mục. 
3. Chọn tên file. 
4. Bấm OK. 

1.3. Cách mở một Design file dưới dạng một Reference file. 

1. Từ thanh Menu ngang của MicroStation chọn File → Reference, xuất hiện 
hộp hội thoại Reference Files. 
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2. Từ thanh Menu của hộp hội thoại Reference files chọn Tools → Attach ..., 
xuất hiện hộp hội thoại Attach Reference File. 

 

 
 

3. Chọn thư mục chứa file bằng cách nhấp đôi vào các thư mục bên hộp danh 
sách các thư mục. 

4. Chọn tên file và bấm OK 
5. Bấm phím OK để đóng hộp hội thoại Attach Reference Files. Khi đó trong 

hộp hội thoại Reference Files sẽ xuất hiện tên file vừa chọn. 
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6. Phím Display đuợc đánh dấu khi muốn hiển thị file. 
7. Phím Snap được đánh dấu khi muốn sử dụng chế độ bắt điểm đối với 

Reference file. 
8. Phím Locate được đánh dấu khi muốn xem thông tin của đối tượng hoặc 

copy đối tượng trong Reference file. 
1.4. Cách đóng một Reference file. 

Trong hộp hội thoại Reference File chọn tên file cần đóng chọn Tools →  
Detach, xuất hiện thông báo: 
 

 
 

 Chọn OK để đóng File Reference, chọn Cancel để hủy bỏ lệnh này. 
1.5. Cách nén file (Compress Design file). 

Khi xoá đối tượng trong Design file, đối tượng đó không bị xoá hẳn mà chỉ 
được đánh dấu là đã xoá đối tượng. Chỉ sau khi nén file thì các đối tượng bị xoá mới 
được loại bỏ hẳn khỏi bộ nhớ. Quá trình nén file sẽ làm cho độ lớn của file giảm 
xuống. Từ thanh Menu của MicroStation chọn File → Compress Design. 

1.6. Cách lưu trữ file dưới dạng một file dự phòng (Save As, Backup). 

MicroStation tự động ghi lại dữ liệu sau mỗi lần thay đổi file active. Vì vậy 
người sử dụng không cần ghi lại dữ liệu sau mỗi lần đóng file active hoặc thoát khỏi 
MicroStation. Tuy nhiên để đề phòng các trường hợp bất trắc, người sử dụng nên ghi 
lại file dữ liệu đó dưới dạng một file dự phòng bằng cách thay đổi tên file hoặc phần 
mở rộng của file. 
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Cách 1: Từ thanh Menu của MicroStation chọn File → chọn Save As... 
1. Ghi lại file đó bằng cách thay đổi tên file nhưng giữ nguyên phần mở rộng 

là dgn. 
2. Chọn thư mục chứa file (Có thể cất trong thư mục cũ) bằng cách nhấp đôi 

vào các thư mục bên hộp danh sách các thư mục. 
Cách 2: Từ của sổ lệnh của MicroStation đánh lệnh BACKUP sau đó bấm 

phím ENTER trên bàn phím. MicroStation sẽ ghi lại file active đó thành một file có 
phần mở rộng là (.bak), tên file và thư mục chứa file được giữ nguyên. 
2.  Cấu trúc file (.dgn), khái niệm Level. 

Dữ liệu trong file dgn được tách riêng thành từng lớp dữ liệu. Mỗi một lớp dữ 
liệu được gọi là một level. Một file dgn nhiều nhất có 63 level. Các level này được 
quản lý theo mã số từ 1-63 hoặc theo tên của level do người sử dụng đặt. 

Các level dữ liệu có thể được hiển thị (bật) hoặc không hiển thị (tắt) trên màn 
hình. Khi tất cả các level chứa dữ liệu được bật, màn hình sẽ hiển thị đầy đủ nội dung 
của bản vẽ. Ta cũng có thể tắt tất cả các level trừ level đang hoạt động gọi là Active 
level. Active level là level các đối tượng sẽ được vẽ trên đó. 

2.1. Cách đặt tên level. 

1. Từ thanh Menu của MicroStation chọn Settings → Level → Names…, xuất 
hiện hộp hội thoại Level Names. 

2. Bấm vào nút Add, xuất hiện hộp hội thoại Level Name. 
 

 
 

3. Number: Mã số level 
4. Name: Tên level (Nhỏ hơn hoặc bằng 16 ký tự) 
5. Comment: Giải thích thêm về tên, có thể có hoặc không (nhỏ hơn hoặc bằng 

32 ký tự). 
6. Bấm OK. 

2.2. Cách đặt một level thành active level. 

Cách 1: Từ của sổ lệnh của MicroStation đánh lệnh lv=<mã số hoặc tên level> 
sau đó bấm phím ENTER trên bàn phím. 

Cách 2: Chọn mã số level từ phím level trên thanh Primary. 
Từ thanh Menu của MicroStation chọn Tools → Primary, xuất hiện thanh 

Primary Tools. Bấm vào phím Active level (phím thứ 2 từ trái sang phải), xuất hiện 
bảng 63 level → kéo chuột đến mã số level cần chọn. 

2.3. Cách bật, tắt level. 
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Cách 1: Từ của sổ lệnh của MicroStation đánh lệnh on=<mã số hoặc tên level> 
sau đó bấm phím ENTER trên bàn phím để bật level cần hiển thị. Trong trường hợp 
muốn bật nhiều level một lúc thì mã số hoặc tên các level cách nhau một dấu “,”. 

Muốn tắt các level thay “on” bằng “of”. 
Cách 2 : Dùng tổ hợp phím <Ctrl+E>, xuất hiện hộp View Levels. 
Các level bật là các ô vuông được bôi đen, các level tắt là các ô vuông có màu 

xám. Mỗi lần bấm con trỏ vào một ô vuông nào đó, ô vuông đó sẽ đổi ngược chế độ từ 
xám sang đen hoặc từ đen sang xám. Sau khi đã chọn xong level cần tắt, bật, bấm 
phím Apply. 
 

 
3. Đối tượng đồ hoạ (Element). 

3.1. Khái niệm đối tượng (element) 

Mỗi một đối tượng đồ hoạ xây dựng lên Design file được gọi là một Element. 
Element có thể là một điểm, đường, vùng hoặc một chữ chú thích. Mỗi một element 
được định nghĩa bởi các thuộc tính đồ hoạ sau: 

1. Level: (1-63)  
2. Color: (1-255) 
3. Line Weight: (1-31) 
4. Line Style: (0-7, custom style) 
5. Fill color: (cho các đối tượng đóng vùng tô màu). 

 
3.2. Các kiểu đối tượng (element type) sử dụng cho các bản đồ số. 

1. Kiểu Element thể hiện các đối tượng dạng điểm: 
- Là 1 Point = Line (đoạn thẳng) có độ dài bằng 0. 
- Là 1 Cell (Một ký hiệu nhỏ) được vẽ trong MicroStation. Mỗi một cell được 

định nghĩa bởi một tên riêng và được lưu trữ trong một thư viện cell (Cell 
Library). 

2. Kiểu Element thể hiện các đối tượng dạng đường: 
- Line: Đoạn thẳng nối giữa hai điểm. 
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- LineString: Đường gồm một chuỗi các đoạn thẳng nối liền với nhau. (số 
đoạn thẳng < 100) 

- Chain: Là một đường tạo bởi 100 đoạn thẳng nối liền nhau. 
- Complex String: Số đoạn thẳng tạo lên đường > 100. 

 
Chú ý: Các element có kiểu là Chain và Complex String, MicroStation không cho phép 
chèn thêm điểm vào đường. 
 

3. Kiểu Element thể hiện các đối tượng dạng vùng: 
- Shape: Là một vùng có số đoạn thẳng tạo lên đường bao của vùng lớn nhất 

bằng 100. 
- Complex Shape: Là một vùng có số đoạn thẳng tạo lên đường bao của vùng 

lớn hơn 100 hoặc là một vùng được tạo từ những line hoặc linestring rời 
nhau. 

4. Kiểu Element thể hiện các đối tượng dạng chữ viết: 
- Text: Đối tượng đồ hoạ ở dạng chữ viết. 
- Text Node: Nhiều đối tượng text được nhóm lại thành một element. 

4. Các thao tác điều khiển màn hình. 

Các công cụ sử dụng để phóng to, thu nhỏ hoặc dịch chuyển màn hình được bố 
trí ở góc dưới bên trái của mỗi một cửa sổ (Window). 

 

 
 

 
 
 
 
1. Update: Vẽ lại nội dung của cửa sổ màn hình đó. 
2. Zoom in: Phóng to nội dung. 
3. Zoom out: Thu nhỏ nội dung. 
4. Window area: Phóng to nội dung trong một vùng. 
5. Fit view: Thu toàn bộ nội dung của bản vẽ vào trong màn hình. 
6. Pan: Dịch chuyển nội dung theo một hướng nhất định. 
7. View previous: Quay lại chế độ màn hình lúc trước. 
8. View next: Quay lại chế độ màn hình lúc trước khi sử dụng lệnh View 

previous. 
 

Chú ý: Sử dụng các lệnh điều khiển màn hình không làm gián đoạn các lệnh đang sử 
dụng trước đó. 
 

5. Cách sử dụng các phím chuột. 

1 2 3 4 5 6 7 8 
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Khi sử dụng chuột để số hoá trên màn hình ta sẽ phải sử dụng thường xuyên 
một trong ba phím chuột sau: Data, Reset, Tentative. 

Phím Data được yêu cầu sử dụng trong các trường hợp sau: 
- Xác định một điểm trên file dgn (Ví dụ khi vẽ đối tượng hoặc chọn đối 

tượng). 
- Xác định của sổ màn hình nào sẽ được chọn (Ví dụ khi sử dụng lệnh fit view 

hoặc update màn hình). 
- Chấp nhận một thao tác nào đó (Ví dụ như xoá đối tượng). 
Phím Reset được yêu cầu sử dụng trong các trường hợp sau: 
- Bỏ dở hoặc kết thúc một lệnh hoặc một thao tác nào đó. 
- Trở lại bước trước đó trong những lệnh hoặc những chương trình có nhiều 

thao tác. 
- Khi đang thực hiện dở một thao tác và thực hiện kết hợp với thao tác điều 

khiển màn hình, thì một (hoặc hai) lần bấm phím Reset sẽ kết thúc thao tác 
điều khiển màn hình và quay trở lại thao tác đang thực hiện dở ban đầu. 

Phím Tentative được yêu cầu sử dụng trong trường hợp bắt điểm (snap). 
 
Cách đặt quy định cho các phím chuột. 
Từ thanh Menu của MicroStation chọn Workspace → Button Assignments,  

xuất hiện hộp hội thoại Button Assignments. 
 

 
 

1. Chọn một phím chức năng. Ví dụ chọn phím Data. 
2. Dịch chuyển con trỏ xuống phần Button Definition area. 
3. Bấm phím chuột (Ví dụ phím trái) muốn sử dụng làm phím đã chọn (Data). 

Nếu chuột chỉ có hai phím thì một trong ba phím chức năng (Thường là 
phím Tentative) sẽ phải dùng cùng lúc hai phím chuột. 

4. Bấm nút Ok. 
6. Các chế độ bắt điểm (Snap Mode). 

Để tăng độ chính xác cho quá trình số hoá trong những trường hợp muốn đặt 
diểm Data vào đúng vị trí cần chọn, phím Tentative sẽ được dùng để đưa con trỏ vào 
đúng vị trí trước. Thao tác đó được gọi là bắt điểm (Snap to Element). Các chế độ 
chọn lựa cho thao tác bắt điểm gồm: 
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1. Nearest: Con trỏ sẽ bắt vào vị trí gần nhất trên element . 
2. Keypoint: Con trỏ sẽ bắt vào điểm nút gần nhất trên element. 
3. Midpoint: Con trỏ sẽ bắt vào điểm giữa của element 
4. Center: Con trỏ sẽ bắt vào tâm điểm của đối tượng. 
5. Origin: Con trỏ sẽ bắt vào điểm gốc của cell. 
6. Intersection: Con trỏ sẽ bắt vào điểm cắt nhau giữa hai đường giao nhau. 
 
Cách bắt điểm 
Chọn Snap Mode bằng một trong hai cách sau: 
1. Từ thanh Menu của MicroStation chọn Settings → Snap, chọn một trong 

những chế độ ở trên. 
2. Từ thanh Menu của MicroStation chọn Settings → Snap → Button Bar, xuất 

hiện thanh Snap Mode. Chọn một trong những biểu tượng tương ứng với 
các chế độ chọn ở trên. 

7. Sử dụng các công cụ trong MicroStation 

Thanh công cụ (Main). 
Để dễ dàng, thuận tiện trong thao tác, MicroStation cung cấp rất nhiều các công 

cụ (drawing tools) tương đương như các lệnh. Các công cụ này thể hiện trên màn hình 
dưới dạng các biểu tượng vẽ (icon) và được nhóm theo các chức năng có liên quan 
thành những thành  những thanh công cụ (Tool box).  

Các thanh công cụ thường dùng nhất trong MicroStation được đặt trong một 
thanh công cụ chính (Main tool box) và được rút gọn ở dạng các biểu tượng. Thanh 
công cụ chính được tự động mở mỗi khi ta bật MicroStation và ta có thể thấy tất cả các 
chức năng của MicroStation trong đó. Ta có thể dùng chuột kéo các thanh công cụ con 
ra thành một Tool box hoàn chỉnh, hoặc chọn từng icon trong tool đó để thao tác. Khi 
ta sử dụng một công cụ nào đo thì tool sử dụng sẽ là hiện thời và chuyển màu thành 
màu sẫm. Ngoài ra đi kèm với mỗi một công cụ được chọn là hộp Tool setting, hộp 
này hiển thị tên của công cụ và các phần đặt thông số đi kèm (nếu có). 

 

1 2 3 4 5 6 
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Thanh công cụ vẽ đối tượng dạng đường, tuyến (Linear Element Tools) 

 

 
 

Thanh công cụ vẽ đối tượng dạng điểm (Points Tools) 
 

 
 

Thanh công cụ vẽ đối tượng dạng vùng (Polygons Tools) 
 

 
Thanh công cụ vẽ đường tròn, ellipses. 

 

 
 

Thanh công cụ vẽ và sửa các đối tượng dạng chữ. 
 

 
 

Thanh công cụ vẽ các ký hiệu dạng cell. 
 

 
 

Thanh Main (Main Tool Box) 

Tool Setting 
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Thanh công cụ trải ký hiệu cho các đối tượng dạng vùng. 
 

 
 
Thanh công cụ dùng để copy, dịch chuyển, thay đổi tỷ lệ, quay đối tượng. 
 

 
 

Thanh công cụ sửa chữa đối tượng dạng đường 
 

 
 
Thanh công cụ dùng để thay đổi thuộc tính của đối tượng. 

 

 
 
Thanh công cụ dùng để liên kết các đối tượng riêng lẻ thành 1 đối tượng 

hoặc phá bỏ liên kết đó. 
 

 
 
Thanh công cụ tính toán các giá trị về khoảng cách hoặc độ lớn của đối 

tượng. 

 
 

Công cụ chọn đối tượng. 
 

 
 
Công cụ xoá đối tượng. 
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Chương 2: Thiết kế các dạng ký hiệu trong MicroStation 

1.  Thiết kế ký hiệu dạng điểm và pattern. 

Các ký hiệu dạng điểm và pattern được tạo thành các cell và chứa trong các thư 
viện cell riêng cho từng loại và từng tỷ lệ bản đồ khác nhau. 

Kích thước các cell khi thiết kế tính theo đơn vị đo chính MU (Master Unit) và 
sẽ bằng kích thước của ký hiệu khi in ra giấy nhân với mẫu số của tỷ lệ bản đồ. 

Trong quá trình thiết kế ký hiệu, người sử dụng phải biết sử dụng một cách kết 
hợp và hài hoà các công cụ, các chức năng giúp vẽ chính xác đối tượng của 
MicroStation. (Tham khảo thêm cách sử dụng các công cụ vẽ đối tượng trong quyển 
MicroStaiton 95 User's Guide) 

Cell type có 2 kiểu cell chính sau: Graphic, Point. Các thuộc tính đồ hoạ của 
một cell dạng graphic được đặt khi vẽ ký hiệu, trong khi các giá trị thuộc tính của một 
cell dạng point sẽ được đặt tại thời điểm vẽ cell. 

Trước khi thiết kế một cell, người sử dụng phải tạo hoặc mở thư viện sẽ chứa 
cell đó, vẽ ký hiệu và tạo ký hiệu đó thành cell. 

1.1. Cách tạo mới một thư viện chứa cell (cell Library). 

1. Từ thanh Menu của MicroStation chọn Element → Cells, xuất hiện hộp hội 
thoại Cell Library. 

 

 
 

2. Từ thanh Menu của Cell Library chọn File → New. Xuất hiện hộp hội thoại 
Create Cell Library. 
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3. Chọn seed file cho cell library bằng cách bấm vào phím Select (Xem phần 
chọn seed file). 

4. Chọn thư mục chứa file. 
5. Nhập tên thư viện cell với phần mở rộng là (.cel) trong hộp text files. 
6. Bấm phím OK. 

1.2. Cách tạo mới một cell. 

1. Mở hoặc tạo mới cell library chứa cell 
2. Vẽ ký hiệu; 
3. Bao fence quanh ký hiệu vừa vẽ. 
4. Chọn công cụ Define Cell Origin. 

 

 
 

5. Bấm phím Data vào điểm đặt ký hiệu. 
6. Trong hộp Cell Library bấm phím Create, xuất hiện hộp hội thoại Create 

New Cell. 

 
 

7. Nhập tên cell vào hộp text Name (≤ 6 ký tự). 
8. Nhập phần giải thích tên cell vào hộp text Description (≤ 27 ký tự). 
9. Chọn kiểu cell. 
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10. Bấm phím Create. 
1.3. Cách xoá một cell khỏi thư viện chứa cell. 

1. Chọn cell trong hộp Cell Library. 
2. Bấm phím Delete. 

1.4. Cách sửa tên cell hoặc phần mở rộng tên cell. 

1. Chọn cell 
2. Bấm phím Edit, xuất hiện hộp hội thoại Edit Cell information. 

 

 
 
3. Đánh tên cell mới và phần mởi rộng vào hộp text Name và Description. 
4. Bấm phím Modify. 

2.  Thiết kế ký hiệu dạng đường. 

Các ký hiệu dạng đường được thiết kế dưới dạng là các kiểu đường custom. Các 
kiểu đường dùng để biểu thị các đối tượng dạng đường của bản đồ được chứa trong 
thư viện kiểu đường (line style library) hay còn gọi là file resource. Ví dụ: DH-50.rsc. 
Để sử dụng được các kiểu đường này, các file resource bắt buộc phải được lưu trong 
thư mục \\win32app\ustation\wsmod\default\symb\*.rsc. 

Trong file resource mỗi một ký hiệu dạng đường được định nghĩa bao gồm tên 
ký hiệu, tên này được gắn với một kiểu định nghĩa đường. Có 3 kiểu định nghĩa 
đường. 

- Kiểu Stroke pattern: Đường được định nghĩa dưới dạng là một nét đứt và 
một nét liền có chiều dài được xác định một cachs chính xác (đơn vị tính 
theo đơn vị chính_MU), lực nét của các nét liền cũng được xác định một 
cách chính xác, màu sắc của đường sẽ được định nghĩa tuỳ theo người sử 
dụng sau này. 

- Kiểu point symbol: Một chuỗi các ký hiệu nhỏ gọi là các point symbol 
(được tạo giống như tạo cell) đặt dọc theo chiều dài của đối tượng, khoảng 
cách giữa các ký hiệu được xác định chính xác (theo đơn vị đo chính) dựa 
trên chiều dài của các nét liển của một đường dạng Stroke pattern. 

- Kiểu compound: Kiểu đường này được tạo nên từ sự kết hợp bất kỳ các kiểu 
đường nào với nhau. Kiểu này thường được sử dụng khi tạo các ký hiệu 
dạng đường vừa thể hiện các nét và các ký hiệu nhỏ trải dọc theo đường. 

Tuỳ vào hình dáng và cách thể hiện ký hiệu dạng đường mà các ký hiệu được 
tạo dựa trên một trong ba kiểu đường trên. 

2.1. Cách tạo mới một thư viện kiểu đường (Line style library). 

1. Chọn công cụ Edit Line style trong thanh Primary Tools. 
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Xuất hiện hộp hội thoại Line style Editor 

 

 
 

2. Từ thanh Menu của hộp hội thoại Line style Editor → File → New, xuất 
hiện hộp hội thoại Create Line Style Library. 
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3. Nhập tên thư viện mới vào hộp text files. 
4. Không thay đổi đuờng dẫn (hoặc đường dẫn phải đúng như trong bảng ví 

dụ). 
5. Bấm phím OK. 

2.2. Cách mở một thư viện kiểu đường (Line Style Library). 

1. Chọn công cụ Edit Line Style trong thanh Primary Tools, xuất hiện hộp hội 
thoại Line Style Editor. 

2. Từ thanh Menu của hộp hội thoại Line Style Editor chọn File → Open, xuất 
hiện hộp hội thoại Open Line Style Library. 

 

 
 

3. Chọn tên thư viện kiểu đường bên hộp danh sách tên files. 
4. Bấm phím OK. 

2.3. Cách tạo mới một đường kiểu Stroke 

1. Mở hoặc tạo mới một thư viện chứa kiểu đường. 
2. Xác định bước lặp của đường và các giá trị độ dài, độ rộng của mỗi nét 

gạch. 
Ví dụ: Kiểu đường mòn của bản đồ địa hình 1/50 000 có bước lặp gồm một nét gạch 
liền và một nét gạch đứt. Độ dài của nét gạch liền sẽ = 1mm × 50 000. Độ dài của nét 
gạch đứt sẽ = 0.8 mm × 50 000. 

3. Từ thanh Menu của hộp hội thoại Line Style Editor chọn Edit → Create →  
Stroke Pattern, xuất hiện dòng chữ New stroke componet bên hộp text 
component. 
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4. Đánh tên mô tả kiểu đường đó thay thế cho dòng chữ new stroke 
component. 

 
 

5. Bấm phím Add trong phần Stroke Pattern để định nghĩa nét gạch đầu tiên. 
6. Bấm con trỏ để chọn nét gạch. 
7. Nhập giá trị độ dài của nét gạch vào hộp text Length (= độ dài nét gạch khi 

in ra giấy × với mẫu số tỷ lệ bản đồ). 
8. Chọn kiểu của nét gạch (Dash là nét liền, Gap là nét đứt). 
 

 

BÊm con trá ®Ó 
chän nÐt g¹ch 
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9. Nếu muốn đặt độ rộng của nét gạch liền (lực nét), chọn mode Width là full 

và nhập giá trị lực nét vào hộp text Start và End. 
 

     
 
  Dash Caps chọn Closed. 
10. Nếu cần định nghĩa nét gạch thứ hai làm lại các bước từ 4-9. 
11. Đặt tên cho kiểu đường bằng cách: Từ thanh Menu của hộp hội thoại Line 

Style Editor chọn Edit → Create → Name, xuất hiện dòng chữ Unname bên 
hộp text Name, nhập tên đường đó thanh thế cho dòng chữ Unname. 

12. Từ thanh Menu của hộp hội thoại Line Style Editor, chọn File → Save để 
ghi lại kiểu đường đó. 

2.4. Cách tạo mới một đường kiểu Point symbol 

1. Mở hoặc tạo mới một thư viện chứa kiểu đường. 
2. Xác định bước lặp của đường, kích thước và hình dáng ký hiệu tạo đường, 

khoảng cách giữa các ký hiệu giống nhau. 
Ví dụ: Kiểu đường ranh giới thực vật của bản đồ 1/50000 có bước lặp là một ký hiệu 
hình tròn, đường kính = 0.2mm × 50000; khoảng cách giữa các ký hiệu = 0.8mm × 
50000. 

3. Vẽ ký hiệu đường. 
4. Bao fence quanh ký hiệu. 
5. Định nghĩa điểm đặt ký hiệu bằng công cụ Define cell origin (Xem phần tạo 

cell). 
6. Chèn ký hiệu vừa tạo vào thư viện kiểu đường bằng cách:  
Từ cửa sổ lệnh của MicroStation đánh lệnh Create symbol tên symbol sau đó 

nhấn phím ENTER trên bàn phím. 
 

 
Khi thấy xuất hiện dòng nhắc Symbol added to line style library, nghĩa là ký 

hiệu đã chèn vào thư viện kiểu đường.  
Tạo đường Base line (đường nền) kiểu stroke pattern để đặt ký hiệu. Bước lặp 

của đường này là một nét liền có độ dài bằng khoảng cách giữa các ký hiệu giống 
nhau. 

Bằng cách: Từ thanh Menu của hộp hội thoại Line style Editor, chọn Edit → 
Create → Stroke Pattern , xuất hiện dòng chữ New stroke component. 

Nhập tên đường Base line đó thay thế cho dòng chữ new stroke component → 
thực hiện tiếp từ bước 4-8 như phần tạo mới kiểu đường stroke. 

7. Từ thanh Menu của hộp hội thoại Line style Editor, chọn Edit → Create → 
Point, xuất hiện dòng chữ new stroke component. 

Nhập tên mô tả đường đó thay thế cho dòng chữ new stroke component. 
8. Chọn vị trí đặt ký hiệu 
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8.1. Chọn Origin khi muốn đặt một ký hiệu vào điểm bắt đầu của đường (Ví dụ 
của đường hình mũi tên). 

8.2. Chọn End khi muốn đặt một ký hiệu vào các điểm cuối của đường (Ví dụ 
các đường hình mũi tên). 

8.3. Chọn Vertex khi muốn đặt một ký hiệu vào các điểm nằm trên đường. 
8.4. Nếu muốn đặt ký hiệu dải đều theo một khoảng cách nhất định bấm vào 

phím  Base stroke pattern để chọn kiểu đường chuẩn. 
 

 
Xuất hiện hộp hội thoại Base stroke pattern chứa các kiểu đường stroke. Bấm 

phím Data vào kiểu đường chuẩn cho ký hiệu cần tạo. 
 

 
 
Bấm OK. 
9. Chọn ký hiệu. 
Bấm chuột vào thanh Base line trước khi chọn ký hiệu. 
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10. Bấm phím Select để chọn ký hiệu. Xuất hiện hộp hội thoại Select Point 
Symbol. 

 
 

11. Bấm chuột để chọn ký hiệu cần tạo. 
 

 
 

Mẫu đường sau khi chọn ký hiệu 
12. Đặt tên cho kiểu đường bằng cách: Từ thanh Menu của hộp hội thoại Line 

style Editor → Edit → Create → Name, xuất hiện dòng chữ Unname bên 
hộp text Name → Đánh tên đường đó thay thế cho dòng chữ Unname. 

13. Từ thanh Menu của hộp hội thoại Line Style Editor, chọn File → Save để 
ghi lại kiểu đường đó. 

2.5. Cách tạo kiểu đường compound 

1. Xác định các đường thành phần và vị trí giữa các đường. 
Ví dụ 1: Kiểu đường đá của bản đồ địa hình 1/50000 gồm hai đường thành phần kiểu 
stroke lực nét 0.15 mm x 50000 và cách nhau 0.4 mm x 500000. 
Ví dụ 2: Kiểu đường dây điện của bản đồ địa hình 1/500000 gồm 4 đường thành phần: 

- Đường kiểu stroke lực nét 0.15 x 50000. 
- Đường kiểu point symbol ký hiệu là một chấm tròn đường kính 0.2mm x 

50000. 
- Đường kiểu point symbol ký hiệu hình mũi tên xuôi kích thước (1; 1) mm x 

50000 cách nhau 18mm. 
- Đường kiểu point symbol ký hiệu hình mũi tên ngược kích thước (1; 1) mm 

x 50000 cách nhau 18mm. 
2. Mở hoặc tạo mới một thư viện chứa đường cần tạo. 
3. Tạo các đường component (Xem cách tạo đường kiểu Stroke và Point 

Symbol). 
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4. Thanh menu của hộp Line Style Editor chọn Eit → Ceate → Compound, 
xuất hiện dòng chữ new compound component bên hộp text Component. 

5. Thay tên mô tả đường cần tạo thay thế cho dòng chữ new compound 
component bên hộp text Component. 

6. Trong hộp Sub-Component bấm phím Insert. 
 

 
 

Xuất hiện hộp hội thoại Select Component. 
 

 
 

7. Dùng con trỏ chọn từng đường thành phần của đường cần tạo một sau đó 
bấm phím OK. 

8. Đặt vị trí cho các đường thành phần theo chiều dọc để tạo khoảng cách cho 
các đường bằng cách: Từ bảng danh sách các đường thành phần trong hộp 
Sub-Component bấm chuột chọn đường cần thay đổi vị trí → nhập giá trị vị 
trí cho đường vào hộp text Offset. Nếu giá trị > 0 → đánh số bình thường; 
nếu giá trị < 0 → đánh thêm dấu (-) đằng trước số. 
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9. Đặt tên cho kiểu đường bằng cách: Từ thanh Menu của hộp hội thoại Line 
Style Editor, chọn Edit → Create → Name, xuất hiện dòng chữ Unname bên 
hộp text Name → nhập tên đường đó thay thế cho dòng chữ Unname. 

10. Từ thanh Menu của hộp hội thoại Line Style Editor, chọn File → Save để 
ghi lại kiểu đường đó. 

2.6. Cách xoá một kiểu đường thành phần. 

1. Bên hộp danh sách các Component chọn tên đường thành phần cần xoá. 
2. Từ thanh Menu của hộp hội thoại Line Style Editor → Edit → Delete để xoá 

kiểu đường thành phần đó. 
2.7. Cách xoá một kiểu đường. 

1. Xoá các đường thành phần tạo lên đường đó (Xem phần trên). 
2. Bên hộp danh sách các tên đường (Names) chọn tên đường cần xoá. 
3. Từ thanh Menu của hộp hội thoại Line Style Editor → Edit → Delete để xoá 

kiểu đường đó. 
3.  Cách sử dụng các font chữ tiếng Việt trong MicroStation. 

Để sử dụng được các font chữ tiếng Việt trong MicroStation, các font chữ dưới 
dạng truetype sẽ được chèn vào một file resource (.rsc) và đặt trong thư mục có đường 
dẫn sau: \\win32app\ustation\wsmod\default\symb\*.rsc. Bạn có thể tạo mới một file 
rsc riêng để chứa các kiểu chữ tiếng Việt bạn muốn hoặc bạn có thể chèn trực tiếp vào 
file font.rsc đã có sẵn trong MicroStation. 

3.1. Cách tạo mới một thư viện (.rsc) chứa các font chữ trong MicroStation. 

Từ thanh menu của MicroStation chọn Utilities →  Install Fonts xuất hiện hộp 
thoại Font Installer. 
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1. Trong hộp hội thoại Font Installer, bên phía Destination File, bấm phím 
New. Xuất hiện hộp hội thoại Create Font Library. 

 

 
 

2. Chọn thư mục chứa file theo đường dẫn như trên. 
3. Nhập tên file mới vào hộp text Files. 
4. Bấm phím OK. 

3.2. Cách mở một thư viện (.rsc) chứa các font chữ trong MicroStation. 
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1. Trong hộp hội thoại Font Installer, bên phía Destination File bấm phím 
Open, xuất hiện hộp hội thoại Open Font Library. 

 

 
 

2. Chọn tên file. 
3. Bấm phím OK. 

 3.3. Cách chèn một kiểu chữ mới vào một thư viện (.rsc) trong MicroStation. 

1. Từ thanh Menu của MicroStation chọn Utilities → Install Fonts ..., xuất hiện 
hộp hội thoại Font Installer. 

2. Mở file font chữ cần chèn. Ví dụ: vharabia và vhavanb.  
Bằng cách: Bấm vào phím Open bên hộp Source File, xuất hiện hộp hội thoại 

Open Source File. 
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- Trong thanh lọc đuôi file Type chọn True Type (.ttf). 
- Chọn thư mục chứa file font chữ cần chèn bằng cách nhấp đôi vào các thư 

mục bên hộp danh sách các thư mục. 
- Chọn các font chữ bằng cách bấm chuột vào tên font, bấm phím Add, xuất 

hiện đường dẫn và tên font chữ trong hộp File List. 
- Bấm phím Done sau khi đã chọn xong font chữ. 
- Khi đó bên hộp Source File của hộp hộI thoại Font Installer xuất hiện danh 

sách các font chữ vừa chọn. 
3. Mở thư viện sẽ chứa font chữ cần chèn. Ví dụ: Mở file thư viện new.rsc. 

 

 
 

4. Bấm con trỏ vào 1 tên font chữ bên hộp Source File → phím Copy sẽ bật 
sáng. 

5. Bấm vào phím Copy. 
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6. Bấm con trỏ vào font chữ vừa copy bên hộp Destination File (new.rsc) 
7. (Nếu muốn) thay đổi tên font trong hộp text Name. 
8. (Nếu muốn) thay đổi thứ tự font trong hộp text Number. 
9. Bấm phím Done khi kết thúc công việc và xoá hộp hội thoại Font installer. 

4. Thiết kế bảng màu. 

4.1. Cách tạo một bảng màu mới. 

1. Từ thanh Menu của MicroStation chọn Settings → Color Table, xuất hiện 
bảng Color Table. 

2. Từ thanh Menu của bảng Color Table chọn File → Save As… 
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Xuất hiện hộp hội thoại Save Color Table. 
 

 
 
3. Chọn thư mục chứa file bên hộp Directories. 
4. Đánh tên bảng màu mới trong hộp text Files. 
5. Bấm OK. 

4.2. Cách thiết kế bảng màu mới cho từng loại bản đồ  

1. Chọn số màu thể hiện đối tượng cần thay đổi thông số (ví dụ màu số 3). 
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2. Bấm nút Change, xuất hiện hộp hội thoại Modify Color <Số màu cần đổi>. 
 

 
 

3. Bấm nút Color Model để chọn phương pháp pha màu. 
Ví dụ: RGB (0-255). 

4. Nhập các thông số mới của từng màu thành phần vào trong 3 hộp text (Red, 
Green, Blue). 

5. Hoặc bấm chuột chọn vào các vùng màu bên bảng mẫu màu. 
6. Bấm phím OK. 
7. Bấm phím Attach để ghi lại các thông số của màu vừa thay đổi và thay đổi 

màu thể hiện đối tượng trên màn hình. 
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Chương 3: Sử dụng các công cụ trong MicroStation 

1. Tạo lưới Km. 

Chú ý cách làm này chỉ áp dụng với những bản đồ lỷ lệ lớn, các đường lưới Km 
thẳng và song song với nhau 

Để tạo được lưới Km các bạn phải làm lần lượt các bước sau: 
- Nhập toạ độ của các điểm. 
- Nối 4 điểm góc khung tạo thành 4 cạnh của khung. 
- Copy các cạnh của khung để tạo thành  các đường lưới Km trong khung. 

1.1. Nhập toạ độ của các điểm. 

Trước khi nhập toạ độ cho các điểm, các thuộc tính đồ hoạ của điểm như Level, 
Color, LineStyle, Weight phải được đặt trước. Các điểm này thường tồn tại dưới dạng 
là một line có độ dài bằng 0 (Xem phần 3 - Chương 1), vì vậy độ lớn của điểm sẽ phụ 
thuộc vào Weight và kiểu đường sẽ không ảnh hưởng đến hình dạng của điểm. 

Cách đặt thuộc tính đồ hoạ cho các điểm. 
Từ thanh công cụ Primary Tools. 
 

 
 
- Bấm vào nút Color, xuất hiện bảng màu để chọn màu. 
- Bấm vào nút Level, xuất hiện bảng 63 level để chọn level. 
- Bấm vào nút Line Style, xuất hiện 7 kiểu đường, chọn kiểu đường số 0. 
- Bấm vào nút Weight, xuất hiện bảng lực mét để chọn lực nét. 
Cách nhập toạ độ điểm  

Chọn công cụ nhập điểm  (Place Active Point) từ thanh công cụ Main của 
MicroStation. 

Trên cửa sổ lệnh của MicroStation gõ lệnh XY=x1,y1 sau đó bấm phím 
ENTER trên bàn phím. 
Ví dụ: x1=9720 ; y1=7660 

 

 
1.2. Nối 4 điểm góc khung để tạo thành 4 cạnh của khung 

- Đặt thuộc tính đồ hoạ cho đường (Xem phần trên). 
- Chọn công cụ vẽ đường. 

 

 
 

- Chọn mode Snap là Keypoint. 
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- Snap vào điểm bắt đầu của một đường. 
- Bấm phím Data để bắt đầu một đường. 
- Snap vào điểm tiếp theo (điểm kết thúc) của đường. 
- Bấm phím Data để kết thúc một đường. 

1. 3. Copy các cạnh khung để tạo thành các lưới Km. 

- Trên thanh Main chọn công cụ Copy parallel. 
 

   
 

- Đánh dấu vào 2 ô Make Copy và Distance trong hộp công cụ Move Parallel. 
- Đặt khoảng cách giữa các đường copy trong hộp text Distance. Ví dụ: 100. 
- Bấm phím Data để chọn một cạnh cần copy của khung. 
- Bấm phím Data để bắt đầu lệnh copy. 
- Bấm phím Reset để kết thúc lệnh. 

Chú ý: Bản đồ địa chính có thể dựng khung bằng phần mềm Famis. 
Bản đồ địa hình dựng khung bằng module Grid Generation trong phần mềm 

I_RAS C 07.02.00. 
2. Cách mở một thư viện chứa cell. 

1. Từ thanh Menu của MicroStation chọn Element → Cells, xuất hiện hộp hội 
thoại Cell Library. 

 

 
 

 
 
2. Từ thanh Menu của Cell Library chọn File → Attach, xuất hiện hộp hội 

thoại Attach Cell Library. 



 
 
 

 

Tài liệu hướng dẫn sử dụng phần mềm MicroStation http://www.ebook.edu.vn 

Trung tâm Thông tin - Bộ Tài nguyên và Môi trường                                                                           

31

 

 
 

3. Chọn thư mục chứa cell bằng cách nhấp đôi vào các thư mục bên hộp danh 
sách các thư mục. 

4. Chọn tên file. 
5. Bấm phím OK để đóng hộp hội thoại Attach Cell Library. 

 

 
 

3. Cách sử dụng công cụ vẽ cell để vectơ hoá các đối tượng dạng điểm. 

1. Chọn cell theo tên cel phía bên trái của hộp hội thoại Cell Library hoặc theo 
hình dạng cell phía bên phải. 

2. Bấm vào phím Placement trong hộp hội thoại Cell Library. 
3. Chọn công cụ vẽ cell. 
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4. Đặt thông số vẽ cell trong hộp Place Active Cell. 
- Active Cell: Tên cell vừa chọn. 
- Active Angle: Góc quay của cell. 
- X Scale: Tỷ lệ theo chiều X. 
- Y Scale: Tỷ lệ theo chiều Y. 
- Chọn chế độ Relative: Khi muốn đặt cell theo đúng các thông số đã đặt. 
- Chọn chế độ Interactive: Khi tỷ lệ và hướng quay của cell không có giá trị 

nhất định. 
3.1. Cách vẽ cell theo chế độ Relative. 

1. Đưa cell đến vị trí cần đặt. 
2. Bấm phím Data. 

 
3.2. Cách vẽ cell theo chế độ Interactive. 

1. Đưa cell đến vị trí cần đặt. 
2. Bấm phím Data. 

 
3. Kéo con trỏ để xác định kích thước của cell. 
4. Bấm phím Data để chấp nhận kích thước ở trên. 
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5. Nếu kích thước chưa đạt yêu cầu bấm phím Reset để chọn lại. 
6. Bấm phím Data để chấp nhận kích thước ở trên. 
7. Quay cell để chọn hướng. 
8. Bấm phím Data để chấp nhận hướng đã chọn ở trên. 
9. Nếu hướng cell chưa đạt yêu cầu → bấm phím Reset để chọn lại. 
10. Bấm phím Data để chấp nhận hướng đã chọn ở trên. 

4. Cách sử dụng công cụ Place Text để vectơ hoá các đối tượng dạng chữ viết. 

1. Khởi động phần mềm gõ tiếng Việt. Ví dụ: ABC hoặc Vietkey. 
2. Chọn công cụ Place Text. 

  
 

3. Đặt thông số của chữ viết trong hộp Place Text. 
Method: 
- By Origin: Kích thước chữ và hướng chữ được đặt theo các thông số đã xác 

định. 
- Fitted: Chữ được đặt giữa hai điểm, kích thước chữa phụ thuộc vào điểm đặt 

chữ. 
- View Independent: Hướng của chữ không phụ thuộc vào hướng của cửa sổ 

hiện thị. 
- Fitted VI: Vừa Fitted vừa View Independent. 
- Above Element: Chữ được đặt trên một đoạn thẳng với một khoảng cách 

định trước, hướng của chữ là hướng của đoạn thẳng. 
- Below Element: Chữ được đặt dưới một đoạn thẳng với một khoảng cách 

định trước, hướng của chữ là hướng của đoạn thẳng. 
- On Element: Chữ được đặt nằm trên một đối tượng đường. 
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- Along Element: Chữ được đặt dọc theo đối tượng (đường, cung tròn, các 
mặt hình học), cách đối tượng một khoảng định trước. Mỗi ký tự được coi 
như là một chữ. 

Height: Chiều cao của chữ (Kích thước chữ khi in x mẫu số tỷ lệ bản đồ). 
Width: Chiều rộng của chữ (Kích thước chữ khi in x mẫu số tỷ lệ bản đồ). 
Font: Số hiệu font và tên font. 
Justification: Điểm đặt chữ 
Active Angle: Góc quay hướng chữ. 
Interchar Spacing: Khoảng cách giữa các ký tự. 
Line Spacing: Khoảng cách giữa đối tượng và chữ khi Method chọn là Above, 

Below, On hoặc Along Element. 
Các thông số trên có thể đặt trong hộp thoại Place Text hoặc trong hộp thoại 

Text (Xuất hiện khi chọn menu Element → Text). Trong hộp thoại Text có thể quy 
định thêm chữ đó có gạch chân hay không (Underline) hoặc độ nghiêng chính xác của 
text (Slant). 

4. Gõ nội dung của chữ trong hộp text Editor. 
 

 
4.1. Cách đặt chữ theo Method By Origin 

Dùng trong trường hợp kích thước và góc quay của chữ theo phương nằm 
ngang là xác định. 

1. Đưa chữ đến vị trí cần đặt. 

2. Bấm phím Data. 
4.2. Cách đặt chữ theo Method Fitted 

Dùng trong trường hợp kích thước và góc quay của chữ theo phương nằm 
ngang là không xác định. 

1. Đưa chữ đến vị trí cần đặt. 
2. Bấm phím Data. 
3. Kéo chuột để xác định kích thước chữ và hướng quay của chữ. 
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4.3. Cách đặt chữ theo Method Above hoặc Below Element. 

Dùng trong trường hợp kích thước chữ xác định, góc quay của chữ theo phương 
của một đối tượng nào đó và cách đối tượng đó một khoảng nhất định. 

1. Đặt lại Line Spacing, khoảng cách giữa chữ và đối tượng bằng cách: 
Từ thanh Menu của MicroStation chọn Element → Text, xuất hiện hộp hội 

thoại Text. Nhập giá trị khoảng cách vào hộp text Line Spacing. 
2. Bấm phím Data để chọn đối tượng nền để đặt chữ. 

 

4.4. Cách đặt chữ theo Method On Element. 

Dùng trong trường hợp kích thước chữ xác định, góc quay của chữ theo phương 
của một đối tượng nào đó và vị trí của chữ nằm trên đối tượng. 
Ví dụ: Chữ ghi chú đường bình độ. 

1. Đưa chữ đến vị trí cần đặt. 
2. Bấm phím Data. 

4.5. Cách đặt chữ theo Method Along Element. 

Dùng trong trường hợp kích thước chữ xác định, vị trí của chữ nằm song song 
với đối tượng và cách đối tượng đó một khoảng nhất định.Ví dụ: Tên sông suối. 

1. Đặt lại Line Spacing, khoảng cách giữa chữ và đối tượng. 
2. Bấm phím Data để chọn đối tượng để đặt chữ. 
3. Bấm phím Data bên trên đối tượng nếu muốn đặt chữ ở bên trên. 

      Bấm phím Data bên dưới đối tượng nếu muốn đặt chữ ở bên dưới.  
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 4.6. Cách sử dụng công cụ Copy and Incretment Text để copy các đối tượng 
chữ viết dạng số. 

Công cụ Copy and Increment Text có tác dụng khi muốn viết các chữ chú thích 
dưới dạng số, và giá trị các số này tăng hoặc giảm theo một giá trị nhất định. 

1. Chọn công cụ Copy and Increment Text. 
 

  
 

2. Đặt giá trị tăng hoặc giảm của đối tượng trong hộp text Tag Increment. 
Ví dụ: 1 

3. Bấm phím Data vào đối tượng cần copy. 
4. Bấm phím Data vào vị trí đặt đối tượng tiếp theo. 

5. Sử dụng Fence trong quá trình thay đổi và sửa chữa dữ liệu. 

Khi cần thay đổi hoặc tác động đến một nhóm các đối tượng trong bản vẽ, cách 
nhanh nhất là nhóm các đối tượng đó trong một fence. Fence là một đường được vẽ bao 
quanh các đối tượng bằng công cụ vẽ fence để gộp nhóm chúng khi thao tác. Nó cũng 
có tác dụng gần giống như khi ta sử dụng công cụ Element Selection để chọn nhóm đối 
tượng. Tuy nhiên khi sử dụng fence, có rất nhiều sự lựa chọn (mode) cho phép tác động 
đến các đối tượng nằm trong cũng như nằm ngoài đường bao fence. Bao gồm: 

Inside: Chỉ tác động đến các đối tượng nằm hoàn toàn bên trong đường bao 
fence. 

Overlap: Chỉ tác động đến các đối tượng bên trong và nằm chờm lên đường bao 
fence. 

Clip: Tác động đến các đối tượng nằm hoàn toàn bên trong fence và phần bên 
trong của các đối tượng nằm chờm lên fence (Khi đó đối tượng nằm chờm này sẽ bị 
cắt ra làm 2 phần bởi đường fence). 

Void: Tác động đến các đối tượng nằm hoàn toàn bên ngoài fence. 
Void-Overlap: Tác động đến các đối tượng nằm hoàn toàn bên ngoài và nằm 

chờm lên đường fence. 
Void-Clip: Tác động đến các đối tượng nằm hoàn toàn bên ngoài fence và phần 

bên ngoài của các đối tượng nằm chờm lên fence (Khi đó đối tượng nằm chờm này sẽ 
bị cắt ra làm 2 phần bởi đường fence). 

5.1. Cách sử dụng fence để tác động đến một nhóm đối tượng. 

1. Chọn công cụ Place Fence. 
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2. Vẽ fence (đường bao) bao quanh đối tượng. 
3. Chọn công cụ tác động đến đối tượng, công cụ này phải sử dụng được với 

fence (Chế độ Use Fence). 
Ví dụ:  Copy element 
 

 
 

Change element attribute 
 

 
 

4. Chọn Mode sử dụng fence. 
5. Bấm phím Data để bắt đầu quá trình tác động. 

5.2. Cách xoá một nhóm đối tượng bằng fence. 

1. Vẽ fence (đường bao) bao quanh đối tượng. 
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2. Chọn công cụ Delete Fence. 
 

 
 
Chọn mode xoá fence trong hộp Delete Fence Content. 

 

 
 

3. Bấm phím Data để chấp nhận xoá nội dung bên trong của fence. 
6. Cách kiểm tra và sửa các lỗi về thuộc tính đồ hoạ. 

6.1. Cách kiểm tra các lỗi về thuộc tính đồ hoạ. 

Sử dụng các thao tác tắt bật level để kiểm tra. 
1. Chuyển level cần kiểm tra thành level active. 
2. Tắt tất cả các level còn lại (of=1-63). 
3. Kiểm tra các đối tượng trên level active. 
4. Sử dụng các công cụ chọn đối tượng để đánh dấu các đối tượng không thuộc 

level đó. 
6.2. Cách chọn đối tượng (Select Element). 

Cách 1: Sử dụng công cụ Element Selection. 
1. Chọn công cụ Element selection. 

 
 

2. Bấm phím Data để chọn đối tượng. 
3. Bấm phím Ctrl trên bàm phím cùng với phím Data trong trường hợp muốn 

chọn nhiều đối tượng. 
Cách 2: Sử dụng công cụ Select By Attributes. 
1. Xem và ghi lại các thông tin của đối tượng bị sai. 
2. Sử dụng công cụ Select By Attributes để chọn đối tượng theo các thuộc tính 

riêng của đối tượng. 
6.3. Cách xem thông tin của đối tượng 

1. Chọn công cụ Element Information. 
 

 
 

2. Bấm phím Data vào đối tượng cần xem, xuất hiện hộp hội thoại Element 
Information. 
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3. Ghi lại các thông tin sau: 
Type: Text. 
Level: 63 
Color: 3 
Style: 3 
Weight: 4 
Text: <643401> (Nội dung đối tượng chữ được chọn). 
Font: 150 (Số thứ tự font) Justification: CC (Điểm đặt chữ Center Center). 
Total length: (Chiều dài của chữ) Total height: (Chiều cao của chữ). 
Cell Name: (Với type là cell header)… 
 

6.4. Cách sử dụng công cụ chọn đối tượng theo thuộc tính (Select By 
Attributes). 

1. Chọn công cụ Select By Attribute. 
Từ thanh Menu của MicroStation chọn Edit → Select by Attributes, xuất hiện 

hộp hội thoại Select By Attributes. 
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Tuỳ vào sự khác biệt về thuộc tính giữa các đối tượng mà từng tiêu chuẩn về 

thuộc tính sẽ được chọn. 
2. Chọn kiểu đối tượng: Bấm con trỏ vào các kiểu đối tượng cần chọn bên hộp 

danh sách các kiểu đối tượng Types. 
3. Chọn level bằng cách bấm vào phím Clear All sau đó bấm con trỏ vào số 

các level cần chọn. 
4. Chọn màu bằng cách đánh dấu vào hộp Color và đánh số màu vào hộp text. 
5. Chọn kiểu đường bằng cách đánh dấu vào hộp Style và bấm vào nút bên 

cạnh hộp text để chọn kiểu đường (Thường là những kiểu đường custom). 
6. Chọn Weight bằng cách đánh dấu vào hộp Weight và đánh số weight vào 

hộp text. 
7. Chọn tên cell bằng cách: Từ thanh Menu của hộp Select By Attributes chọn 

Settings → Cell. Xuất hiện hộp hội thoại Select By Cell, gõ tên cell vào hộp 
text Cell Name. 

 
 

8. Chọn text theo các thuộc tính của text bằng cách: 
Từ thành Menu của hộp Select by attribute chọn Settings → Text, xuất hiện hộp 

hội thoại Select By Text. 
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Nếu biết được thông tin của đối tượng chữ cần chọn có thể: 
- Đánh dấu và nhập số font text vào hộp Font. 
- Đánh dấu và nhập chiều cao text vào hộp Height. 
- Đánh dấu và nhập chiều rộng text vào hộp Width. 
- Đánh dấu vào nút Justification và chọn điểm đặt text. 
- Đánh dấu và nhập nội dung của text vào hộp String. 

7. Sử dụng các công cụ được dùng để sửa chữa dữ liệu dạng đường. 

Sau quá trình số hoá, dữ liệu dạng đường thường gặp các lỗi: 
- Đường chứa nhiều điểm thừa làm tăng độ lớn của file dữ liệu. 
- Đường chưa trơn, mềm. 
- Tồn tại các điểm cuối tự do, thường xảy ra trong các trường hợp đường bắt 

quá (overshoot), bắt chưa tới (overshoot). 
- Đường trùng nhau (dupliacate). 

7.1. Cách lọc bỏ các điểm thừa của đường. 

Xử lý từng điểm một bằng công cụ Delete vertex của MicroStation. 
1. Chọn công cụ Delete vertex. 

 

 
 

2. Bấm phím Data vào điểm cần xoá. 
7.2. Cách làm trơn đường (Smooth). 

Smooth là quá trình làm tròn đỉnh góc được tạo thành giữa hai đoạn thẳng của 
một đường. Quá trình này còn được gọi là quá trình làm trơn đường hoặc làm mềm 
đường. 

Thêm từng điểm một bằng công cụ Insert Vertex của MicroStation. 
1. Chọn công cụ Insert Vertex. 

 

 
 

2. Bấm phím Data vào đoạn đường cần chèn điểm. 
3. Bấm phím Data vào vị trị cần chèn điểm. 

7.3. Cách sử dụng các công cụ Modify. 

 

 
 

Chú ý: Dùng kết hợp với chế độ Snap nếu có thể. 
1. Modify Element (Dịch chuyển điểm): 
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- Chọn công cụ Modify Element. 
 

 
 

- Bấm phím Data  để chọn điểm cần dịch chuyển → Dịch con trỏ đến vị trí 
mới → Bấm phím Data. 

2. Delete Part of Element (Xoá một phần của đường): 
- Chọn công cụ Delete Part of Element. 

 

 
 

- Bấm phím Data vào điểm bắt đầu của đoạn đường cần xoá → Bấm phím 
Data và kéo chuột để xoá đoạn đường cần xoá → Bấm phím Data tại điểm 
cuối của đoạn đường cần xoá. 

3. Extend Line (Kéo dài đường theo hướng của đoạn thẳng cuối của đường): 
-  Chọn công cụ Extend Line. 

 

 
 

- Bấm phím Data vào điểm cuối của đoạn đường cần kéo dài → Bấm phím 
Data và kéo chuột để dài đoạn đường → Bấm phím Data tại vị trí mới của 
điểm cuối của đường. 
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4. Extend 2 Elements to Intersection (Kéo dài hai đường tại điểm giao nhau 
của hai đường): 

- Chọn công cụ Extend 2 Elements to Intersection. 
 

 
 

- Bấm phím Data chọn đường thứ nhất → Bấm phím Data chọn đường thứ 
hai → Bấm phím Data để thực hiện. 

5. Extend Element to Intersection (Kéo dài một đường tại điểm giao nhau của 
hai đường): 

- Chọn công cụ Extend Element to Intersection. 
 

 
 

- Bấm phím Data chọn đường cần kéo dài → Bấm phím Data chọn đường cần 
gặp → Bấm phím Data để thực hiện. 

6. Trim Element (Cắt một đường hoặc một chuỗi các đường tại điểm giao của 
chúng với một đường khác): 

- Chọn công cụ Trim Element. 
 

 
 

- Bấm phím Data chọn đường làm chuẩn → Bấm phím Data chọn đường cần 
cắt → Bấm phím Data để thực hiện. 
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7. Insert Vertext (Thêm điểm): 
- Chọn công cụ Insert Vertext. 

 

 
 

- Bấm phím Data chọn đoạn đường cần thêm điểm → Dịch con trỏ đến vị trí 
cần chèn điểm → Bấm phím Data để thực hiện. 

 
8. Delete Vertext (Xoá điểm): 
- Chọn công cụ Delete Vertext. 

 

 
 

- Bấm phím Data chọn điểm cần xoá → Bấm phím Data để thực hiện. 

8. Sử dụng các công cụ được dùng để sửa chữa dữ liệu dạng điểm. 

Sau khi số hoá, các lỗi thường gặp đối với dữ liệu dạng điểm (cell): 
- Sai các thuộc tính đồ hoạ (level, color, linestyle, weight). (Xem phần 6). 
- Cell được đặt không đúng vị trí. 
- Cell được chọn không đúng hình dạng và kích thước quy định. 

8.1.  Cách sửa các lỗi sai về vị trí. 
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1. Chọn công cụ Move Element. 
 

 
 

2. Bấm phím Data để chọn đối tượng. 
3. Dịch con trỏ đến vị trí mới của đối tượng và bấm phím Data. 
Có thể thực hiện dịch chuyển cùng lúc nhiều đối tượng bằng fence hoặc select 

element. 
8.2. Cách sửa các lỗi sai về hình dạng và kích thước. 

Cách 1: Dùng cho những cell chỉ sai về kích thước. 
1. Chọn công cụ Scale Element. 

  
 
2. Đặt tỷ lệ cần đổi cho đối tượng trong hộp X Scale và Y Scale. 
3. Bấm phím Data chọn đối tượng cần thay đổi. 
4. Bấm phím Data để đổi kích thước đối tượng. 
Có thể chỉ cần đổi tỷ lệ chiều X hoặc Y khi bỏ chức năng khoá bằng cách bấm 

phím Data vào biểu tượng. 
Cách 2: Dùng cho những cell sai cả về kích thước lẫn hình dáng. 
1. Vẽ lại cell mới với hình dáng, kích thước đúng theo quy định. 
2. Tạo cell với tên cell giống tên cell cũ (Xem phần 1 - Chương 2). 
3. Chọn công cụ Replace Cell. 

 

 
 

4. Bấm phím Data vào cell cần đổi. 
9. Sử dụng các công cụ được dùng để sửa chữa dữ liệu dạng chữ viết. 

Sau khi số hoá, các lỗi thường gặp đối với dữ liệu dạng chữ viết (text): 
- Sai các thuộc tính đồ hoạ (level, color, linestyle, weight). 
- Text được đặt không đúng vị trí. 
- Text được chọn không đúng kiểu chữ và kích thước quy định. 
- Sai nội dung của text. 
- Với các lỗi về thuộc tính đồ hoạ (Xem phần 6). 
- Với các lỗi về vị trí (Xem phần 8). 

9.1. Cách sửa các lỗi sai về kiểu chữ và kích thước. 
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1. Chọn công cụ Change Text Attribute. 
 

 
 

2. Đặt lại các thuộc tính cho text trong hộp Change Text attribute. 
 

 
 

- Đánh dấu và chọn kiểu chữ trong hộp Font. 
- Đánh dấu và đặt lại giá trị kích thước chữ trong hộp text Height và Width. 
- Đánh dấu và đặt lại khoảng cách giữa các dòng trong hộp Line Spacing. 
- Đánh dấu và đặt lại khoảng cách giữa các ký tự trong hộp Interchar Spacing. 
- Đánh dấu và đặt lại độ nghiêng của chữ trong hộp Slant. 
3. Bấm phím Data chọn đối tượng text cần đổi. 
4. Bấm phím Data để chấp nhận đổi. 

9.2. Cách sửa các lỗi sai về nội dung. 

1. Chọn công cụ Edit Text. 
 

 
 
2. Bấm phím Data để chọn đối tượng text cần đổi nội dung. 
3. Thay đổi nội dung Text trong hộp Text Editor. 

 

 
 
4. Bấm phím Apply. 
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Chương 4: Biên tập và trình bày bản đồ. 
Các đối tượng bản đồ khi được thể hiện bằng màu sắc và ký hiệu phải đảm bảo 

được tính tương quan về vị trí địa lý cũng như tính thẩm mỹ của bản đồ. Các đối tượng 
dạng vùng cần tô màu hoặc trải ký hiệu, các đối tượng đó phải tồn tại dưới dạng shape 
hoặc complex shape. Đối với các đối tượng dạng đường, các dữ liệu sau khi số hoá, 
chỉnh sửa và làm đẹp được thay đổi ký hiệu và biên tập lại. 

Chương này hướng dẫn các bạn các cách đóng vùng, tô màu, trải ký hiệu, cách 
thay đổi ký hiệu dạng đường và cách sử dụng một số các công cụ có thể sử dụng kèm 
theo khi biên tập các ký hiệu dạng đường. 
1. Đóng vùng tô màu, trải ký hiệu. 

Hướng dẫn: 
- Cách tạo vùng trực tiếp từ các công cụ vẽ shape của Micro. 
- Cách tạo vùng gián tiếp từ các đường bao của vùng. 
- Cách tạo 1 vùng từ những vùng thành phần. 
- Cách thay đổi kiểu màu của vùng. 
- Cách trải ký hiệu. 

1.1.  Cách tạo vùng trực tiếp từ các công cụ vẽ shape của MicroStation. 

Cách vẽ các vùng vuông góc. 
1. Chọn công cụ Place Block. 

 

 
 

2. Chọn method trong hộp Place Block. 
 

 
 

3. Chọn kiểu tô màu (Fill Type). 
 

 
4. Chọn màu nền. 
5. Bấm phím Data chọn góc thứ nhất. 
6. Nếu Method là Rotate, bấm phím Data chọn góc tiếp theo để chọn hướng 

quay. 
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7. Bấm phím Data chọn góc đối diện với góc thứ nhất. 

 
   Cách vẽ các vùng có hình dạng bất kỳ. 

1. Chọn công cụ Place Shape. 
 

 
 

2. Chọn kiểu tô màu (Fill Type). 
3. Chọn màu nền. 
4. Bấm phím Data vẽ điểm đầu tiên của vùng. 
5. Tiếp tục bấm phím Data để vẽ các điểm tiếp theo. 
6. Để đóng vùng, snap và bấm phím Data vào điểm đầu tiên. 

 
1.2. Cách tạo vùng gián tiếp từ các đường bao của vùng. 

Dữ liệu dùng để tạo vùng phải đảm bảo các yêu cầu sau: 
- Đường bao các đối tượng vùng phải khép kín. 
- Không tồn tại các điểm cuối tự do (đường bắt quá hoặc bắt chưa tới). 
- Phải tồn tại những điểm nút tại những chỗ giao nhau. 
Để đảm bảo các yêu cầu trên của dữ liệu, sử dụng các công cụ hoàn thiện dữ 

liệu sửa hết các lỗi khép kín vùng, điểm cuối tự do sau đó dùng MrfClean để cắt đường 
tự động tại những điểm giao. 

Cách tạo vùng bằng công cụ Create complex shape 
1. Chọn công cụ Create Complex Shape. 

 

 
 

2. Chọn  Method tạo vùng trong hộp Place Complex Shape. 



 
 
 

 

Tài liệu hướng dẫn sử dụng phần mềm MicroStation http://www.ebook.edu.vn 

Trung tâm Thông tin - Bộ Tài nguyên và Môi trường                                                                           

49

 

 
 
3. Chọn kiểu tô màu (Fill Type). 
4. Chọn màu nền. 
5. Bấm phím Data chọn đường bao đầu tiên của vùng. 
6. (Nếu method là Manual) bấm phím Data chọn vào đường bao tiếp theo. 

(Nếu method là Automatic) bấm phím Data con trỏ sẽ tự động chọn đường 
bao tiếp theo. Trong các trường hợp tại ngã ba hoặc ngã tư của những đường 
giao nhau, nếu con trỏ chọn đúng → bấm phím Data, nếu con trỏ chọn sai 
→ bấm phím Reset. 

7. Tiếp tục làm giống như 6. 
8. Vùng sẽ tự động được tạo khi đường bao cuối cùng đóng kín vùng được 

chọn. 
Cách tạo vùng bằng công cụ Create Region 
1. Chọn công cụ Create Region. 

 

 
 

2. Chọn Method tạo vùng là Flood. 
 

 
 
3. Chọn chế độ Keep Original nếu muốn giữ lại đường bao vùng. 

 

 
 

4. Chọn kiểu tô màu (Fill Type). 
5. Chọn màu nền. 
6. Bấm phím Data vào một điểm bất kỳ bên trong vùng cần tạo. 
7. Con trỏ sẽ tự động tìm kiếm và chọn các đường bao xung quanh vùng. 
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8. Khi con trỏ đã chọn hết các đường bao tạo vùng, bấm phím Data để chấp 
nhận vùng cần tạo. 

1.3. Cách tạo một vùng từ những vùng thành phần. 

Cách gộp vùng. 
1. Chọn công cụ Create Region. 
2. Chọn Method tạo vùng là Union 
3. Chọn chế độ Keep Original nếu muốn giữ lại các vùng thành phần. 
4. Chọn kiểu tô màu (Fill Type). 
5. Chọn màu nền. 
6. Bấm phím Data chọn vùng thứ nhất. 
7. Bấm phím Data tiếp tục chọn các vùng tiếp theo. 
8. Sau khi đã chọn hết các vùng cần chọn, bấm phím Data để chấp nhận vùng 

cần tạo. 

Cách trừ vùng. 
1. Chọn công cụ Create Region. 
2. Chọn Method tạo vùng là Difference 
3. Chọn chế độ Keep Original nếu muốn giữ lại các vùng thành phần. 
4. Chọn kiểu tô màu (Fill Type). 
5. Chọn màu nền. 
6. Bấm phím Data chọn vùng thứ nhất. 
7. Bấm phím Data tiếp tục chọn các vùng tiếp theo. 
8. Sau khi đã chọn hết các vùng cần chọn, bấm phím Data để chấp nhận vùng 

cần tạo. 

 
Cách tạo một vùng là phần giao nhau giữa 2 hoặc nhiều vùng. 
1. Chọn công cụ Create Region. 
2. Chọn Method tạo vùng là Intersection 
3. Chọn chế độ Keep Original nếu muốn giữ lại các vùng thành phần. 
4. Chọn kiểu tô màu (Fill Type). 
5. Chọn màu nền. 
6. Bấm phím Data chọn vùng thứ nhất. 
7. Bấm phím Data tiếp tục chọn các vùng tiếp theo. 
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8. Sau khi đã chọn hết các vùng cần chọn, bấm phím Data để chấp nhận vùng 
cần tạo. 

 
Cách tạo các vùng thủng 
1. Chọn công cụ Group Holes. 

 

 
 

2. Bấm phím Data chọn vùng bao bên ngoài. 
3. Bấm phím Data lần lượt chọn các vùng con bên trong. 
4. Vùng thủng sẽ được tạo sau khi các vùng con bên trong đã được chọn hết. 

 
1.4. Cách thay đổi kiểu màu của vùng. 

1. Chọn công cụ Change Element to Active Fill Type. 
 

 
 
2. Đặt lại kiểu màu tô cho vùng trong hộp Change Element to Active Fill Type. 

 

 
 

3. Bấm phím Data chọn vùng cần đổi màu. 
4. Bấm phím Data tiếp theo để chấp nhận màu đổi. 

1.5. Cách trải ký hiệu. 

Đối tượng dùng để trải ký hiệu phải là các đối tượng vùng. Các ký hiệu này tồn 
tại dưới dạng các nét gạch (line) hoặc các ký hiệu nhỏ (cell) được đặt cách nhau theo 
một khoảng cách và góc quay xác định. 

 
Trải ký hiệu dưới dạng các nét gạch. 
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1. Chọn công cụ Hatch Area. 
 

 
2. Đặt các thông số cho nét trải trong hộp Hatch area. 
 

 
 

- Spacing: Khoảng cách giữa các nét gạch. 
- Angle: Góc nghiêng của các nét gạch. 
- Chọn Associative Pattern khi đó các nét gạch và đường bao sẽ trở thành 1 

đối tượng. Nghĩa là khi đối tượng bị thay đổi các nét gạch cũng thay đổi 
theo. 

- Chọn Method là Element 
3. Chọn màu sắc và kiểu đường cho các nét gạch (các nét gạch luôn nằm trên 

level của đối tượng vùng đó). 
4. Bấm phím Data chọn đối tượng. 
5. Bấm phím Data tiếp theo để chấp nhận trải nét. 

 
Trải ký hiệu dưới dạng các nét gạch chéo nhau. 
1. Chọn công cụ Crosshatch Area. 

 

 
 

2. Đặt các thông số cho nét trải trong hộp Crosshatch Area. (Tương tự như 
Hatch Area - Xem phần trên). 
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3. Chọn màu sắc và kiểu đường cho các nét gạch (các nét gạch luôn nằm trên 
level của đối tượng vùng đó). 

4. Bấm phím Data chọn đối tượng. 
5. Bấm phím Data tiếp theo để chấp nhận trải nét. 

 
Trải ký hiệu dưới dạng các ký hiệu nhỏ. 
1. Mở thư viện chứa ký hiệu (cell) cần trải. (Xem phần 2,3 - Chương 3). 
2. Chọn ký hiệu cần trải, bấm phím Pattern. (Xem phần 2,3 - Chương 3). 
3. Chọn công cụ Pattern Area. 

 

 
 

4. Đặt các thông số cho ký hiệu trong hộp Pattern area. 
 

 
 

- Pattern Cell: Tên ký hiệu. 
- Scale: Tỷ lệ ký hiệu. 
- Row Spacing: Khoảng cách giữa các ký hiệu theo chiều ngang. 
- Column Spacing: Khoảng  cách giữa các ký hiệu theo chiều dọc. 
- Angle: Góc quay giữa các ký hiệu. 
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5. Đặt thông số về màu sắc và lực nét cho ký hiệu (level đặt ký hiệu sẽ cùng 
với level của vùng).  

6. Bấm phím Data chọn vùng cần trải. 
7. Bấm phím Data để chấp nhận trải ký hiệu. 

 
2. Biên tập ký hiệu dạng đường. 

Đối với các đối tượng dạng đường, khi tồn tại ở dạng dữ liệu thì nó phải gặp 
nhau tại các điểm nút và nó là một đối tượng đường duy nhất. Nhưng để thể hiện nó 
dưới dạng ký hiệu bản đồ thì có thể phải thể hiện nó bằng hai hoặc ba kiểu đường.Vì 
vậy muốn thể hiện các đối tượng bản đồ dạng tuyến bằng ký hiệu bạn nên làm theo 
trình tự các bước sau: 

- Xác định các kiểu ký hiệu dạng đường cần sử dụng để thể hiện. Bạn phải 
dựa vào thư viện kiểu đường mà bạn có để lựa chọn các kiểu đường bạn sẽ 
dùng. Ví dụ: để thể hiện kiểu đường nhựa trong bản đồ địa hình, bạn sẽ phải 
sử dụng hai kiểu đường: một kiểu đường viền màu đen và một kiểu đường 
nền màu nâu. Bạn sẽ không chọn được kiểu đường đơn thể hiện hai màu 
khác nhau. Hoặc có thể bạn sẽ phải sử dụng thêm một kiểu đường nữa để 
thể hiện đoạn đường đắp cao. 

- Nếu cần từ hai kiểu đường trở lên người sử dụng phải copy đường đã số hoá 
với lệnh copy giữ vị trí. 

- Thay đổi kiểu đường. 
- Sửa chữa và biên tập lại theo yêu cầu. Các công cụ được sử dụng chủ yếu 

nằm trong thanh Modify. Cách sử dụng các công cụ này đã trình bày trong 
Phần 7 - Chương 3. Đối với những kiểu đường compound (Đường được tạo 
gồm nhiều đường thành phần), nếu bạn gặp khó khăn khi sửa chữa thì bạn 
có thể sử dụng công cụ Drop Line Style để phá vỡ mối liên kết đó. 

2.1. Cách copy 1 đối tượng cần giữ nguyên vị trí. 

1. Chọn công cụ copy đối tượng 
2. Bấm phím Data chọn đối tượng cần copy. 
3. Trên của sổ lệnh của MicroStation đánh lệnh Dx=0,0 sau đó bấm phím 

Enter trên bàn phím. 
2.2. Cách thay đổi kiểu đường. 

1. Chọn công cụ Change Element Attribute. 
2. Chọn kiểu đường cần đổi bằng cách: 
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Từ thanh công cụ Primary → bấm vào hộp Linestyle → Custom, xuất hiện hộp 
LineStyle. Bấm vào nút Show Detail để hiển thị kiểu đường được chọn. 

 

 
 
 
Nhấp đôi phím trái chuột vào tên kiểu đường cần chọn hoặc nhấp chuột vào 

đường sample ở dưới. 
3. Khi thấy xuất hiện tên kiểu đường cần đổi trong hộp text Style của hộp công 

cụ Change Element Attribute, bấm phím Data vào đường cần  đổi. 
Chú ý: Nút Style phải được đánh dấu. 
 

 
 

 2.3. Cách sử dụng công cụ Drop Line Style. 

1. Từ thanh Menu của MicroStation → chọn Tools → Drop, xuất hiện 
thanh công cụ Drop. Chọn công cụ Drop Linestyle. 

 

 
 

2. Bấm phím Data chọn đường cần drop. 
3. Bấm phím Data lần thứ hai để chấp nhận drop đường. 
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